
 

  



Introduction 

 

Habitat mapping has been common practice for decades in environmental management, but has only 

recently become efficient and user-friendly for regular mapping updates. Such time series of habitats are 

vital for monitoring change that may be evaluated to guide targeted management efforts. This manual 

will guide the user in creating habitat maps using WorldView and Landsat satellite imagery. Results should 

be useful for stakeholders in policy making and conservation practices.   

 

This manual is an output from the 2018-2019 NOAA/NERR Collaborative Science Catalyst Grant awarded 

to Co-PIs Frank Muller-Karger and Matthew McCarthy, with Brita Jessen as collaborative lead from the 

Rookery Bay National Estuarine Research Reserve (NERR). That project, Mapping Terrestrial and Benthic 

Habitat Change to Address Mangrove and Seagrass Migration and Die-off in Response to Recent and 

Long-term Environmental Drivers, used WorldView and Landsat imagery to map habitats throughout the 

100,000-acre reserve from 2010-2018, which included the impact of category 3 Hurricane Irma after it 

made landfall in the reserve in September of 2017. 

 

For information please visit the NERRS project webpage 

(http://www.nerrssciencecollaborative.org/project/MullerKarger18) or contact the author at 

mjm8@mail.usf.edu. 
 

 

 

 

 

 

 

 

http://www.nerrssciencecollaborative.org/project/MullerKarger18


LANDSAT, SPOT, and other high spatial and spectral resolution satellite image systems 

(Credit: Frank Muller Karger, University of South Florida) 

There are four types of resolution when discussing satellite imagery in remote sensing: 

- Spatial resolution is defined as the pixel size of an image representing the size of the surface area 

(i.e. m2) being measured on the ground, determined by the sensors' instantaneous field of view 

(IFOV).  

- Spectral resolution is defined by the wavelength interval size (discreet segment of the 

Electromagnetic Spectrum) and number intervals that the sensor is measuring; 

- Temporal resolution is defined by the amount of time (e.g. days) that passes between imagery 

collection periods for a given surface location;  

- Radiometric resolution is defined as the ability of an imaging system to record many levels of 

brightness (contrast for example). Radiometric resolution refers to the effective bit-depth of the 

sensor (number of greyscale levels) and is typically expressed as 8-bit (0-255), 11-bit (0-2047), 12-

bit (0-4095) or 16-bit (0-65,535).  

 

 

 

 

 

 

 

 

 

 

 

 

  

 

 

 

 

 

 



HOW TO DOWNDOAD LANDSAT DATA? 

1. In a web browser, navigate to: landsatlook.usgs.gov 

2. Click on Start LandsatLook Viewer 

 
 

3. Once the page opens, select the Years, Days of the year, Maximum cloud cover 

(recommended that you keep it to 20%), Select the sensor (e.g. in this image Landsat 8 OLI 

(2013-present) was selected. In the search window type your area of interest (e.g. Viti Levu, Fiji) 

and Click on Show Images. 

 

4. As you can see below, the image appears in different layers. Under Metadata and Data Access, 

check the Displayed Images Only (Table View). 



 

 

5. Once the Displayed Images Only (Table View) is selected, another windows opens up. Check 

on one of the Scene ID (e.g. the recent one is selected) and click on Show Footprint(s) tab. 

 

6. The area of the image will be selected as shown in light blue square. Click on Add to cart. 



 

7. Click on Go to Cart tab. 

 

 

 



8. Check the file and click on Get Landsat Data tab. 

 

9. New windows will appear, Get Landsat Data, click OK. 

 
 



10. Item basket window will open. In the last column, there is two icon, one is download icon and 

other one is X. Click on download icon 

 

 

 

11. Another windows will open. In order to work with ENVI, we need the Geo TIFF file e.g. click on the 

Download tab next to Level 1 Geo TIFF Data Product (837.6 MB) 



 
 

12. The file is now downloading. 

 
 



13. Once the download is complete. Open the Downloads folder, select the downloaded file, right 

click on it, and go to 7-Zip and then Extract files. 

 
 

 

 

 

14. Extract files window will open, click on the …. Tab to select your file destination. 



 

 

15. Click OK on the Browse for Folder and OK on the Extract window. The data file will now start 

extracting as shown below. 

 



 
 

16. Once the extraction is complete, go to the folder where you have saved the file and right click 

on it, go to 7-zip and extract file again to unzip the folder. In the Extract window, just click OK(Do 

not need to select the folder again). 

 



 

17. File is being extracted again and you will see that a new folder is created with the file name. 

Open the folder and you will see the images in each band. 

 

 



HOW TO CLASSIFY LANDSAT DATA? 

Open ENVI classic. Go to file open, Ctrl the TIF files you want to work with. Click Open. 

 

Available bands windows opens up. Check on RGB Color and Select your bands.  

N.B as per Landstat 8 (Source: http://landsat.usgs.gov/band_designations_landsat_satellites.php), 

Landsat 8 Operational Land Imager (OLI) and Thermal Infrared Sensor (TIRS) images consist of nine spectral bands with a spatial 

resolution of 30 meters for Bands 1 to 7 and 9. New band 1 (ultra-blue) is useful for coastal and aerosol studies. New band 9 is 

useful for cirrus cloud detection. The resolution for Band 8 (panchromatic) is 15 meters. Thermal bands 10 and 11 are useful in 

providing more accurate surface temperatures and are collected at 100 meters. Approximate scene size is 170 km north-south by 

183 km east-west (106 mi by 114 mi). 

Landsat 8 

Operational  

Land Imager  

(OLI)  

and  

Thermal  

Infrared  

Sensor  

(TIRS)  

 

Launched 

February 11, 2013 

Bands 
Wavelength 

(micrometers) 

Resolution 

(meters) 

Band 1 - Coastal aerosol 0.43 - 0.45 30 

Band 2 - Blue 0.45 - 0.51 30 

Band 3 - Green 0.53 - 0.59 30 

Band 4 - Red 0.64 - 0.67 30 

Band 5 - Near Infrared (NIR) 0.85 - 0.88 30 

Band 6 - SWIR 1 1.57 - 1.65 30 

Band 7 - SWIR 2 2.11 - 2.29 30 

Band 8 - Panchromatic 0.50 - 0.68 15 

Band 9 - Cirrus 1.36 - 1.38 30 

Band 10 - Thermal Infrared (TIRS) 1 10.60 - 11.19 100 * (30) 

Band 11 - Thermal Infrared (TIRS) 2 11.50 - 12.51 100 * (30) 

* TIRS bands are acquired at 100 meter resolution, but are resampled to 30 meter in delivered data product. 

http://landsat.usgs.gov/band_designations_landsat_satellites.php


 

For Red, Click on Band 1 under TIFF Band 4 image (LC80750722015169LGN00_B4) 

For Green, Click on Band 1 under TIFF Band 3 image (LC80750722015169LGN00_B3) 

For Blue, Click on Band 1 under TIFF Band 2 image (LC80750722015169LGN00_B2) 

 

Once all is selected, click on Load RGB. 

 

This is how you file will look like now. You can move the cursor around the Scroll window to view or zoom 

to your area of interest. 



 

It becomes important to stack to layers to make classifying easier. As you can see on the Available 

bands that all layers (bands) appear separate. 

HOW TO DO LAYER STACKING? 

Go to ENVI Classic- click on Basic Tools, then on Layer stacking. 

 

Layer Stacking Parameters window will open. Under Selected files for Layer Stacking, there is an Import 

File tab, click on it, 

 



Click on open drop down list and select, New file. 

 

Navigate to the folder you have saved your file, press CTRL and select the TIFF images you want to be 

layered. Click Open. 

 

Now you have all the selected images under your Select Input File. Press CTRL, select the 8 images as 

shown below and Click OK. 

 

The Layer Stacking Parameters window will open. Type Layer_Stacking under Enter Output Filename. 

Other default parameters look ok. Click on OK. 



 

Create Layer File will be processed as shown below. 

 

 

Available Bands window will open and now you have all the selected banded under Layer_Stacking as 

shown below. 

 

Your layers are stacked and now you the ready to classify them. 

CheckRGB color and select your bands as shown below: 



Red- Band 4 

Green – Band 3 

Blue- Band 2 

 

Click on Load RGB. In drop down Display tab, you can view as Display #1 or Click on New Display. 

You are now ready to follow the Classification Tutorial. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



CLASSIFICATION USING ENVI CLASSIC 

Open ENVI Classic 

 

Open image>>>chose image file>>>open (if Landsat 8, under RGB choose Band 4 for Red,  

                                        Band 3 for green 

  Band 2 for blue 

 

        Load RGB>>> image display window opens 

 

In the ENVI Classic window>>>click on classification>>>Unsupervised>>>ISODATA 

In the classification input file window>>>select the file name you used to open the first image (if you    

                                                                        have masking option then you can click the select mask    

     band tab) 

 

     Click OK 

 

The ISODATA Parameters window will open 

 

Choose the number of classification you would want to see 

 

Enter output filename >>>and rephrase the name by adding " _ISODATA" 

 

Available band window will open>>>click on the ISODATA file you created for all; R,G,B 

 

     Choose new display>>>click on load RGB  

 

* Repeat the same steps for K-Means (to see the difference between ISODATA and K-Means) 

     

 

 

 

  



ENVI 5.3 (Masking and FLAASH Atmospheric Correction) 

Radiance: 

- is the measurement of light 

- is the measurement for calibrations 

- looks at one single angle 

 

Eradiance: 

- all the light that can be collected at all different angles 

 

*Need to use MTL.text for calibrations 

Masking 

ENVI 5.3 >>>Open MTL>>>it will open the Landsat image automatically 

Toolbox>>>search Mask>>>click apply mask>>>in the window, select the MTL.txt file with highest number of bands 

 

Spatial subset (leave it as it is)>>>select mask band>>>mask options>>>click on build mask 

 

         Import ROI>>>select ROI file 

 

    Select the output name e.g. mask_envi>>>Apply mask parameters window opens 

 

         Leave mask value as 0 

 

        Enter output filename e.g. applied_mask_envi 

 

          Click OK 

 

 

 

 

 

 

 



FLAASH Atmospheric Correction 

 

ENVI 5.3 >>>Open MTL>>>it will open the Landsat image automatically 

Toolbox>>>Radiometric Correction>>>Radiometric calibration (select mask file in window after building mask) 

 

File selection (select multispectral with image preview)>>>spatial subset (subset with file) 

 

Click OK 

 

Radiometric calibration window>>> check if Radiance is there>>>Apply FLAASH settings 

 

Output file e.g. calibrated_subset>>> Click OK (wait for Radiometric calibration to load *blue loading bar) 

 

A new image opens (this image will be used for FLAASH atmospheric corrections) 

 

 

 

Toolbox>>>Radiometric Correction>>>Atmospheric Correction>>>> Flaash atmosphere 

 

FLAASH Atmospheric correction model input parameters window opens ( use file you calibrated in page 1 e.g. 

calibrated_subject; use default values- check ◘ single scale factor for all bands) 

Output>>> e.g. subset_calibrated_flaash 

Output directory of new files >>>create a folder called flaash files 

Sensor type: Multispectral (Landsat TM 7 or Landsat 8 or WV2 - depends which imag eis being used) 

Flight date>>> change as per the information on MTL.txt file 

  e.g. Date acquired: 2013-10-10 

  scene center time = 22 (hr): 08(min): 45(sec) 

 

Atmospheric model:  Tropical   Aerosol Model :Maritime 

      Aerosol Retrieval : 2-Band over water 

 

 

 



WORLDVIEW IMAGERY PROCESSING 

 Sections 

o Data Acquisition 

o Pre-processing 

o Processing (classification) 

o Post-processing 

o Data acquisition 

o WorldView satellite imagery are commercially owned and distributed 

o Images may be distributed free of charge to those individuals whose position or 

organization have access through the NextView License 

o All Federal Agency staff, and academics with a current NASA- or NSF-funded grant 

should be covered by the license 

o Images should be ordered through the DigitalGlobe online portal at: 

http://evwhs.digitalglobe.com 

 First-time users will have to set up an account as verified by DigitalGlobe 

o Preprocessing 

 Data management 

 Unzip any images or files - store in logical order/location 

 Create folders for output files from calibration, atmospheric correction, and any 

other anticipated steps – this helps keep files organized 

 Calibration and atmospheric correction in ENVI 5.3 - this should be the first preprocessing 

step taken for all images (i.e. prior to any subsetting, georectification, orthorectification, 

co-registration, etc.) because those steps may resample the image, which may 

rearrange or reorient pixels. Atmospheric correction is most accurate when applied to 

the raw image in its original orientation as delivered/downloaded. Calibration applies 

gain and offset corrections to data and converts the data to an appropriate format for 

FLAASH atmospheric correction. 

 Radiometric calibration - converts raw image data (digital numbers) to radiance 

or reflectance 

o WorldView Radiance tool (ENVI Classic) 

o Basic Tools>Preprocessing>Calibration Utilities>WorldView 

Radiance 

 Select 8-band NTF image 

 Select unzipped corresponding IMD file 

 Output to Floating Point (necessary for FLAASH) 

http://evwhs.digitalglobe.com/


 

 The output will then need to be converted to a BIL file format using 

the Convert Data tool: Basic Tool>Convert Data 

 

o Radiometric Calibration tool (ENVI 5.3 64-bit) 

 Open MTL Landsat image file (i.e. metadata file; note that this tool 

does not work well with WorldView imagery) 

 Select FLAASH settings 

 FLAASH - Fast Line-of-sight Atmospheric Analysis of Hypercubes is an advanced 

method of atmospheric correction 

 For Landsat 1, 2 and 3 (Multispectral Scanner sensor), FLAASH may not perform 

properly, so a technique called Dark Object Subtract is recommended. This tool 

can be found in the ENVI>Spectral>Spear toolbox. Follow prompts and evaluate 

the output to ensure the results appear accurate. 

 Deglinting (as needed for images with substantial sunglint; Note: this will render terrestrial 

habitats unusable). 

 Download deglint.sav file: https://geonet.esri.com/thread/43308 and save it to 

C:\Program Files\Exelis\ENVI53\classic\save_add 

 Start ENVI Classic + IDL (must start both) 

 Open image to be deglinted 



 Create and save ROI of pixels over deep water (i.e. no visible benthos) 

containing glint as well as relatively glint-free water, if possible 

 

 Spectral>Deglint - Select file and associated ROI, then select Band 8 (NIR2) as NIR 

band, and output to filename 

 

 Geometric Correction and Projecting - images come in a geometric coordinate system, 

which may cause distortions in the display depending on the geographic location of the 

image ground track. Images should be projected to an appropriate, local coordinate 

system to avoid these issues. 

 Use ENVI's WorldView Orthorectification tool 

(Map>Orthorectification>WorldView>Orthorectify WorldView) 

o Choose Cubic Convolution for resampling as this is the most accurate 

(although it takes longer than the others). 



 

 DEM - this step is necessary for study areas that are higher in elevation 

than sea-level. It accounts for the elevation when displaying the 3-

dimensional image in 2 dimensions on a screen. Requires a digital 

elevation model (DEM) of same resolution or better. If working in area at 

sea-level or with flat terrain, no DEM is necessary and a fixed height is 

selected. 

 Fiji Map Grid is, unfortunately, not an option in ENVI, so choose UTM zone 

60S, WGS datum. 

 Reproject the image using ENVI's Reproject Raster tool, or export the 

orthorectified image as a TIFF (File>Save File As), open in ArcMap, and use the 

Project tool (Data Management Tools>Projections and 

Transformations>Raster>Project Raster). 

o Choose Cubic Convolution for resampling, and Rigorous for warping 

method as these are the most accurate (although they take longer than 

the others); choose Fiji Map Grid Projected Coordinate System. 



 

 Co-registration - corrects minute discrepancies in images covering the same geographic 

location such that pixels align more accurately. This step is required for change detection 

or time series analyses, but not for studies wherein only one image is used for a given 

area. 

 Subsetting - clips a large image to a smaller area of interest (i.e. reduces file size and 

eliminates areas that are otherwise distractions) 

 Optionally exclude areas of exposed reef from analysis because their spectral 

profiles will be substantially different from those of their submerged counterparts 

o To identify exposed areas, perform a Normalized Difference Water Index 

(NDWI) using the Band Math tool. Enter this expression: float(b1-

b2)/float(b1+b2)>OK>Assign b1 to the Coastal band, and b2 to the NIR2 

band (i.e. bands 1 and 8, respectively). Run. 

o In the output image, use the Cursor Location/Value tool (right-click) to 

scan the NDWI image and choose a threshold value appropriate for your 

image's water pixels - this tends to be approximately 0.0-0.3 and above. 

o Use this NDWI file to create a mask (see below under Classification) 

 Create a shapefile in ArcGIS of the area to be subset (i.e. your region of interest). 

 Open in ENVI as vector file and convert to EVF or ROI file 

 Subset via ROIs tool - follow prompts. 

 If the output contains areas outside the desired region of interest, export 

the file as a TIFF, open in ArcMap, and subset using the Extract by Mask 

tool (Data Management>Spatial Analyst>Extraction). Then import the 

subset image in ENVI again for the classification (ArcGIS offers 



classification tools, but ENVI tools tend to afford more versatility with 

options). 

o Processing 

 Classification 

 Unsupervised 

o Classification>Unsupervised - choose either ISOdata or K-means (ISO is 

more rigorous but more time-consuming). 

o Select the image to be classified (after radiometric calibration, 

atmospheric correction, and subsetting). 

o Select only the visible bands for the image (i.e. exclude bands in 

the Infrared spectrum; Landsat bands 1-4; WorldView-2 bands 1-6). 

o If using a mask (e.g. to exclude exposed areas identified by the NDWI 

step), click Mask Options dropdown>Build Mask>Options 

dropdown>Import Data Range - select the NDWI file and click OK, then 

input the value you identified as your water threshold (e.g. 0.3) in Data 

Min Value and click OK (leave Data Max Value blank). Save the mask as 

an output file. To mask other areas of an image, this same process can be 

used by selecting a different file and data min or max value. 

o ISODATA Parameters 

 Number of classes: this should be twice the number of expected 

thematic classes (e.g. if you expect sand, seagrass, coral, rubble, 

and water, Min classes should be 10; Max classes can be 15 or 

more). 

 Maximum iterations: equal to the Max classes # 

 Change Threshold: 5.0% 

 Minimum # Pixel in Class: 20 

 Max Class Stdv: 1.0 

 Min Class Distance: 5.0 

 Max # Merge Pairs: 2 

 Max Stdev from Mean: blank 

 Max Distance Error: blank 

 Output to filename 

 OK to run 

 Supervised 

 Open image to be classified and display it. 

 Open training shapefiles: File>Open Vector File - follow prompts to output 

shapefiles to .evf files in the appropriate coordinate system. 

 Load the .evf files onto the same display as the image to be classified. 

 Repeat this process for the shapefiles to be used as validation. 

 Classification>Supervised>Maximum Likelihood (ML is the most robust and 

commonly used of these options). 

 Select the image to be classified (after radiometric calibration, 

atmospheric correction, and subsetting). 

o Select only the visible bands for the image (i.e. exclude bands in 

the Infrared spectrum; Landsat bands 1-4; WorldView-2 bands 1-6). 

 Follow mask directions as above, if necessary. 



 Select ROI files to be used for training (note: the number of points per ROI 

must be greater than the number of bands used in the classification or 

you will receive an error). 

 Save the output file and (optionally) the rule maps. 

 OK to run. 

o Post-processing 

 Class color mapping (Unsupervised) 

 Open classified image - Tools>ColorMapping>Class Color Mapping 

 Use a reference image to assign each spectral class to a thematic class (e.g. 

Class 1 assigned to Sand) 

 Save changes 

 Combine classes (Unsupervised) - after color mapping, if you have, for example, 3 

classes representing Sand, these need to be combined into one Sand class for analysis. 

 Classification>Post Classification>Combine Classes - Select classified image - Click 

the first of one thematic class in the left column, then click the first of the same 

thematic class in the right column, then click Add Combination; repeat by 

matching classes in the left column with only one match in the right column (i.e. 

only select one class from the right column for each thematic class, but assign all 

classes from the left column - these will disappear as they are combined). 

 OK - Remove Empty Classes: No 

 Output to filename 

 Accuracy assessment 

 Classification>Post Classification>Confusion Matrix>Using Ground Truth ROIs 

 Select classified image (must have validation ROIs open first) 

 Match validation ROIs to image classes 

 OK - select output variables - OK 

 Evaluate accuracy from output table; save table. 

 Change detection 

 Basic Tool>Change Detection>Statistics - Select the oldest image as your "initial" 

and your more recent image as "final". Leave the default statistic outputs, and 

output the files to a filename/folder. OK. 

 Below is an example output table showing the Pixel Count change. 

 To read the table, columns (e.g. values below "Marsh") represent the 

number of pixels that were classified as Marsh in the initial image. Rows 

(e.g. values right of "Marsh") represent the number of pixels that were 

classified as Marsh in the final image. The box where column Marsh meets 

row Marsh (231670) indicates the number of pixels that did not change 

from their original classification of Marsh (i.e. they were classified as Marsh 

in both the initial and final images). The box where column Marsh meets 

row Scrub (39706) indicates the number of pixels that changed from 

Marsh to Scrub; Marsh pixels that changed to Forest is 527, etc. These 

change and no-change values, in Area and Percentage, are the most 

common to report. Also important is the Class Changes row toward the 

bottom. This number plus the no-change box for each class should equal 

complimentary Class Total value, or 100% under the Percentage tab. 



 Also, a series of maps called "Masks" should have been produced that display the 

change from each class to the rest. Visualize these in comparison with the output 

table to check that changes make sense. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

FIELD WORK 

 

 Sections 

o Preparation 

o In-field data collection 

o In-lab data processing 

 Preparation 

o Create transect points (if desired) 

 Convert line to points 

 Create new feature class (point feature) 

 Open Editor>Select transect line(s) 

 Click Editor drop down>Construct Points - select number of points and 

distance - Okay 

 Save Edits, stop editing 

o Create Data Dictionary file in GPS Pathfinder 

 Utilities>Data Dictionary Editor - assign Name - New Feature - assign Feature 

Name and Classification type (e.g. point) - OK; New Attribute - assign type (i.e. 

Text, Date, etc.) - OK; Save file. 

o Create file on GPS hand-held device in TerraSync 

 Turn off collection of points between target features: Setup>Logging 

Settings>select "Off" on all "Interval" drop-down menus (the purpose of this is to 

avoid collecting undesired data points between target features, which can 

conflict with target data points when exporting them as shapefiles). 

o Create data files necessary for field work (e.g. transect lines, site location points, 

base/background raster or vector files) in GIS or other spatial data software. 

 Background file: must be a .ecw or .sid file; otherwise, the file will need a 

.wld (World) file containing projection metadata - World file can be 

created in GIS using the Export Raster World File tool. 

o Transfer files to hand-held GPS device for use in field. 

 Load data files (e.g. shapefile transects or points) into GPS Pathfinder 

 Import - select shapefile 

o Choose Import Setup (change coordinate system, etc. as desired) 

- OK 

 Transferring data between PC and hand-held GPS device (here is a good video 

describing it: https://www.youtube.com/watch?v=A7_FkcRAVAo) 

 Connect device to PC via USB cable 

 Open Windows Mobile Device Center to connect device to PC 

(download software from https://fpimgis.wordpress.com/i-cant-connect-

my-windows-mobile-device-to-a-computer/) 

 Click "Connect without setting up your device" - the next screen should 

say "Connected" with a green check mark 

o If "Not Connected" is displayed on PC, unplug USB from device, 

navigate to Setting>Connections>USB to PC - toggle the checkbox 



on or off - OK, then reconnect device and check connection. If 

that doesn't help, shutdown the hand-held device, and power 

back on. Mobile Device Center app should open automatically. 

 Open GPS Pathfinder Office and click Data Transfer on the left side of the 

window 

 Data transfer should automatically connect to the device. If not, select 

device from drop-down menu and click Connect. 

 To transfer data from the handheld device, click the "Send" or "Receive" 

tab, depending on desired direction, then click "Add" on the right. Select 

the file type, and navigate to the desired file, then select it, click "Open", 

and click "Transfer All" on the lower right side of the Data Transfer screen. 

 Data should be transferred to the PC or device for use. 

o  

 In-field data collection 

o Turn on and connect GPS receiver and hand-held device 

 First time: open Settings in Trimble main menu - Bluetooth>COM Ports>New 

Outgoing Port>Select Pro########>Next>COM#>Finish. Open 

TerraSync>Setup>GNSS Settings>Select the COM# assigned to the Pro receiver in 

the drop-down 

o Use hand-held device to navigate to study site (e.g. transects) if desired; otherwise, 

simply collect points at study site (note: avoid spatial autocorrelation by evaluating 

spatial autocorrelation distance first, if possible, then collecting future points at 

appropriate distance). 

 Data>New>File type: Rover, Location: Default, assign File Name, Dictionary 

Name: select pre-assigned dictionary file with attribute information 

 Collect Features>Point_generic - click Log (if does not start automatically), 

optionally add a comment/name for the point, wait until at least 30 positions 

have been collected (count in top right of screen), then click Done - point should 

be logged. 

 In-lab data processing 

o Transfer collected GPS points file to PC (see instructions above) 

o Open file in GPS Pathfinder Office (File>Open) 

o Apply Differential Correction from base station 

(https://www.youtube.com/watch?v=3vZ8lGWI-fQ) 

 Download base files from ftp://ftp.ga.gov.au/geodesy-

outgoing/gnss/data/highrate/2016/ 

 Download and unzip all files corresponding to the same local time as data 

points were collected. 

 Select .SSF file, Base Data - Folder Search>Navigate to fold where base files were 

saved. Reference position - Use position from downloaded base files. 

 Select Base Data - Browse (third option)>Browse folder - select downloaded base 

file; Reference Position: Use position from downloaded base files; check the box 

Confirm base data and position before processing 

o Export GPS file to shapefile (https://www.youtube.com/watch?v=Jd2WSqjwoZE) 



  

o Load file into spatial data software (e.g. ArcGIS or ArcMap) 

o Export file three times (i.e. 2 copies) to shapefile - this is so that if you make mistakes in 

later editing, you have an original copy of the data to use. 

o Define projection - points should align properly, but will not have a defined geographic 

coordinate system. 

 Data Management Tools>Projections and Transformations>Define Projection - 

input the shapefile, select Projected Coordinate System, and navigate to the 

system used in data collection (check the settings in the hand-held device if 

necessary). 

o Check points - use field pictures and log sheet to check that each point is correctly 

assigned to its appropriate habitat class 

 Open Attribute table - Add Field - give a name; short integer is fine. 

 Selection>Select by Attributes - double-click "Comment" field to select, click "Like" 

button, type 'a%' to select all the variables assigned to the "algae" class (note: this 

assumes a data collection field for comments was included in field work and 

"algae" was  an included target class). OK. 

 In attribute table, right-click on the Habitat field header and click Field Calculator 

- OK to warning message - type "1" or "algae" or otherwise in the box below. OK. 

This will populate the Habitat field for all the selected "algae" points with a new 

value (e.g. 1). 



 Repeat this process for all classes, changing the value assigned (e.g. 1,2,3,4...). 

 Now that you have created a new field, you can edit this field without changing 

the raw data. View each point on top of the orthorectified and projected image 

to be classified to ensure that it lies in the correct location on the image. 

Compare the image habitat assigned with the corresponding field picture and 

log sheet to ensure that the point is assigned to the correct habitat. When 

satisfied, close attribute table. Changes will be automatically saved. 

 Create new shapefiles for each habitat's group of points. Select by Attributes 

each class one at a time. Right-click the shapefile>Data>Export Data - assign an 

output location and filename and click OK. A new shapefile will be created 

including only the selected points. Repeat this process for the remaining classes. 

o Create new "line" feature class for each transect 

o Open Editor>Start Editing - select new line feature class - click Create Features button (far 

right of Editor toolbar) - select line feature class, Construction Tools: Line - snap to start 

and end transect points, right-click: Finish Sketch - save edits - click new line segment to 

select - Editor>Construct Points 

 

Satellite Processing Principles 

 WorldView-2 Imagery 

o Products are delivered by provider as Level 1B - this means that the images have been 

corrected for detector variations in the sensor (i.e. radiometric correction), and distortions 

of geometry in the image. To be useful for mapping, the images must be further 

radiometrically calibrated using the provided absolute calibration coefficients, projected 

into an appropriate local coordinate system, and geometrically corrected by registering 

the image to an existing base map. In mountainous regions, terrain can affect the 

geometry of the image, and further rectification may be needed (i.e. orthorectification). 

Field-Work Principles 

 When classifying satellite images, ground-truthing is needed  to train supervised classifications, 

and to evaluate the accuracy of the maps produced. The later is a vital component to any 

mapping project - without validation, a map is effectively useless because one cannot 

determine how accurate it actually is. 

o Conducting field work requires a GPS unit with horizontal accuracy that is higher than the 

pixel resolution of the satellite imagery that will be used. A rule of thumb is to collect GPS 

points with horizontal accuracy better than half the resolution of the image (i.e. sub-

meter accuracy for 2 m pixel resolution). 

o Points may be collected in two general ways: identifying in lab the locations to be 

sampled prior to field work, or collecting points in the field based on access and 

feasibility. The former is generally better, as it allows one to plan an unbiased, random 

sampling pattern, but may neglect challenges that only become apparent once in the 

field. This issue may be avoided with visits to the site prior to field work. The latter method 

is typically faster, but must be justified. Acceptable justifications may include: poor pre-

processed (i.e. in-field) GPS accuracy precluding one from reaching pre-selected 



sampling locations accurately; difficult terrain that would likely hamper random data 

collection; or thick canopy cover obscuring challenging terrain. 

o Both methods require that points are collected such that they do not introduce error 

from spatial autocorrelation. This means that, for study areas with relatively homogenous 

terrain, points collected in close proximity to each other are statistically likely to be of the 

same habitat class, and are therefore not random. Spatial autocorrelation may be 

assessed by collecting points at a consistent distance (e.g. 5-meter intervals) along 

several parallel transects. The points may later be evaluated using a software program 

such as R to determine at what distance points in the given study area are not spatially 

autocorrelated. Field work may then proceed by sampling points at the given distance 

(e.g. 20-meter intervals) or greater. 


